HELP Vivitar slide printer problem : LUSENET : polaroid transfers : One Thread

Posted to Polaroid transfer also but I tought this was a more appropriate subject heading. Got the Vivitar, loaded batteries, loaded film. The light to view slides is on but no READY light and no FLASH (I tried anyway). The TIMER light works when i hit the time button but still no READY light. ANy suggestions or is this a total loss? Someone who asked a similar question was asked if their Vivitar hummed when it was turned on. Mine doesn.t Just the light goes on and...silence. Thanks judy

-- judy tillinger (, June 11, 2003


I can't get my printer to flash either. Have you had any luck in resolving your problem? The ready light goes on but there is no flash when pressing the PRINT button; I spoke with one camera repair facility and they said that the switch goes bad but there are no parts available for the repair.

-- Stan Morris (, August 18, 2003.

To update the above item it turned out that, for some reason, that particular printer didn't work with batteries, only with the AC adapter which the seller had tested it with. I didn't have an AC adapter so I returned it and the seller sent another which works well. Thank you to all the folks who've contributed suggestions and good luck to others with similar probs.

-- judy tillinger (, August 22, 2003.

Moderation questions? read the FAQ